Meson can't find luaJIT on mac

  • BecauseICanTM
    27th January Member 0 Permalink

    Hi,

     

    I just cloned a fresh copy of TPT (2 times, actually) and get an error:

     

    meson.build:79:1: ERROR: Dependency "luajit" not found, tried pkgconfig, framework and cmake

     

    (full log here)

     

    I followed the instructions to compile, and luajit as well as the other dependencies are installed.

     

    Am I doing something wrong? Help!

  • LBPHacker
    27th January Developer 0 Permalink
    Has homebrew actually succeeded in installing luajit? Ignore, I'm blind. Well, in this case, the only thing I can suggest is looking at what files luajit installed, most notably finding the pkg-config file for it (something with .pc in its name) and figuring out what name it's available under (since it's apparently not "luajit").
    Edited once by LBPHacker. Last: 27th January
  • BecauseICanTM
    27th January Member 0 Permalink

    @LBPHacker (View Post)

     Yep.

     

    % brew reinstall luajit

    ==>Downloading https://homebrew.bintray.com/bottles/luajit-2.0.5.big_sur.bottle

    Already downloaded: /Users/[me]/Library/Caches/Homebrew/downloads/da616aec726266836f3b91dc04b825c655a54e86154569db766d7700193f60bc--luajit-2.0.5.big_sur.bottle.3.tar.gz

    ==>Reinstalling luajit 

    ==>Pouring luajit-2.0.5.big_sur.bottle.3.tar.gz

    ????  /usr/local/Cellar/luajit/2.0.5: 31 files, 2.0MB

     

    Exact same result.

  • LBPHacker
    27th January Developer 0 Permalink
    I'd hoped to be able to edit my previous comment before you posted another one, see above.
  • BecauseICanTM
    27th January Member 0 Permalink

    @LBPHacker (View Post)

     Whoops! Sorry!

     

    UPDATE: I had to set PKG_CONFIG_PATH to /opt/local/lib/pkgconfig, so then it recognized it, and now it can't find libcurl.

    Edited once by BecauseICanTM. Last: 27th January
  • LBPHacker
    27th January Developer 0 Permalink
    The guide doesn't make you install libcurl because it seemed to be installed by default on 10.5, but maybe you need to install it manually on 11. I think what you need is the "curl" package, but I only base that on the fact that the "libcurl" package does not exist. I can't provide anything better than educated guesses because I don't have access to a 11 machine :/ Anyway, if you figure it out, we'll update the guide.
    Edited once by LBPHacker. Last: 27th January
  • BecauseICanTM
    27th January Member 0 Permalink

    Yes! It worked! pip seems to not install meson and ninja correctly, so I used brew, curl needs to be installed by brew, and my .zshrc needed this put in:

     

    export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/local/lib:usr/local/share/pkgconfig:/opt/local/lib/pkgconfig:/usr/local/opt/curl/lib/pkgconfig

     

    So, to put it in from the command line, it'd be

     

    echo "export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/local/lib:usr/local/share/pkgconfig:/opt/local/lib/pkgconfig:/usr/local/opt/curl/lib/pkgconfig" >> ~/.zshrc

     

    Then, everything works! Thanks!

  • happykrcheese
    28th January Member 0 Permalink

    There are a lot of issues in mac developing..

  • jacob1
    28th January Developer 0 Permalink
    @Cheese_KR (View Post)
    Always have been, especially when there is a new macOS release. Your issue and the issue hear appear to be issues in pip / curl / etc. They will need to be updated so that they can be installed properly on the latest version of macOS.

    It does seem like the new build system, meson, works without issues on mac :) (nobody has reported any problems with that yet, only with issues getting dependencies installed)
  • happykrcheese
    28th January Member 0 Permalink

    But why didn't I get any issues with luajit? I'm running the same Big Sur 11.