Bug that will make TPT not want to run

  • JustAPlayer
    29th March Member 0 Permalink

    I was once messing around with stamps and my TPT hung up. I closed it and opened it again but it won't show up. I looked in Task Manager and it turned out TPT was just sitting there as a background process, doing absolutely nothing. It wasn't using my CPU, it wasn't writing or reading my hard disk. I then replaced The Powder Toy.exe file with another one, freshly downloaded from the website, and then tried starting it up again. This time it worked. My stamps and saves saved on my hard disk were all fine, because I only replaced the TPT executable in my TPT folder. What caused this, and will it be fixed?

  • jacob1
    29th March Developer 0 Permalink
    This is very unlikely to be a bug. I'd blame Windows before blaming powder toy for this. powder toy was probably not running, I'm not sure why task manager had it listed.
  • Lord_Bowserinator
    29th March Member 0 Permalink

    This sounds like that bug with the stamps I found (the memory error). When that happened some of the threads in TPT didn't close properly and left behind some background processes. You can just kill the processes.

     

    LBPHacker fixed the bug, I'm guessing the fix will be shipped with the next release.

  • JustAPlayer
    30th March Member 0 Permalink

    It would just not show up every time I started it, before replacing the exe file. I opened it up, it won't show up, I ended the process in Task Manager, opened it up again, doesn't work. Replaced the .exe file, now works.