Windows Defender won't let me run TPT.

  • EastGermanyIsTheBest
    11th March Member 0 Permalink
    When I right-click and click run, Windows Defender does not allow me to run it. It does not provide the box 'Run', only 'Don't Run'.

    It says it's a risk to the computer.
    Edited once by EastGermanyIsTheBest. Last: 11th March
  • Rashoneh
    11th March Member 0 Permalink

    TPT doesn't have any virus, ignore clicking "Don't Run" button.

     

    EDIT: what abbout screenshot? is it your OS windows 10 or windows 8? 

    Edited once by Rashoneh. Last: 11th March
  • EastGermanyIsTheBest
    11th March Member 0 Permalink
    @Rashoneh (View Post)
    But there is no other button to press other than Don't Run.

    It is windows 10, and I am unable to post screenshots here.
    Edited once by EastGermanyIsTheBest. Last: 11th March
  • LBPHacker
    11th March Developer 0 Permalink
    Welcome to the army of users whose operating system and/or antimalware thinks TPT is a virus. We can't do anything about it other than shoving a hash of the binary down every single (anti?)malware vendor's throat out there every time there's a new version. Which we may or may not do, depending on how annoying it is to do. What *you* can and should do is add an exception for TPT in Defender.
  • EastGermanyIsTheBest
    11th March Member 0 Permalink
    What am I supposed to do? I've play TPT before, I really enjoy the game, I want to play the game again. What do I do.
  • jacob1
    11th March Developer 0 Permalink
    I've never needed to add an exception to run TPT on Windows, while Defender is enabled. Maybe the "run anyway" button is hidden?

    Just open the search and find "windows defender", i'm not sure about the specifics of adding the exception.
  • Supercrafter
    11th March Member 0 Permalink

    @EastGermanyIsTheBest (View Post)

     

     Add. A. Exception. 

  • jacob1
    11th March Developer 0 Permalink
    ok I figured out the real problem.

    Open windows search and search for "App & Browser Control"

    There should be an option "Check apps and files". There are 3 options, Block, Warn, and Off. You have it set to "Block", which blocks everything from running downloaded from the internet, regardless of what it is. Change it to either Warn and you'll be able to run TPT.
    Edited once by jacob1. Last: 28th April
  • EastGermanyIsTheBest
    11th March Member 0 Permalink
    Fixed
  • coolstuf
    26th March Member 0 Permalink

    when you have windows defender on and it says " windows protected your pc" click on more info and a button will appear that says "run anyway" than it will run.