Official Game Feedback

  • furlong_p
    19th February Member 0 Permalink

    Well, not exactly. The keyboard problem lies elsewhere. The fact that the keys are in different places, for each layout, is not the issue. Let's take the German layout as an example:

     

    The character for "Reset Pressure" is the "=". That character, for the German layout, is on the same key as the 0. We press Shift+0 to get a =. But, Shift+0 doesn't work. Neither does Ctrl+Shift+0 (Reset sparks).

     

    It's worse for the square brackets. These are on the 8 and 9 keys, as the third assignment. We create those brackets by pressing Ctrl+Alt+8 and Ctrl+Alt+9, respectively (alternative is AltGr+8 and AltGr+9).

     

    So, the problem is, that these characters do not have their own keys on the keyboard, at all. They share the same key with other hotkeys, and thus conflict with them. The previous 93 version just assumed US layout, so we pressed the key where they would have been on the US layout.

  • jacob2
    19th February Member 0 Permalink
    @furlong_p (View Post)
    Thanks, that will be really helpful for fixing this issue

    I didn't realize the old version assumed US layout until after I released 94.0. During the beta, I got some reports by tptmp users, so I assumed the problem was only with tptmp. That issue was known. But I didn't realize everything else with those layouts were also broken.

    I'll test using the keys you mentioned, once I fix it. I already added German keyboard layout to my computer so I could test stuff.
  • DarkGlaze12
    19th February Member 0 Permalink

    Help me after updating the game to version 94, when I press the left mouse button, the "copying" mode is activated (ctrl + left mouse button) I can’t put an element properly, please help me I can play this game with comfort if I need more detailed information You will have to make a video in the screenshot that will not get shown.

  • furlong_p
    19th February Member 0 Permalink

    Did you try pressing both CTRL keys shortly? Sometimes modifier keys in Windows tend to get stuck (i. e. Windows 'thinks' they are pressed permanently). Pressing both CTRL keys shortly should correct that "sticky keys" problem.

  • Paulo_fofis
    19th February Member 0 Permalink

    "Oh my heart".

    now has a button in the settings to on / off the decor layer. I loved it. I just think that the boot settings of the upper right corner should enable / disable the decorations not the Newtonian gravity

    I love this version, You guys thought a lot about TPT mobile users.

  • jacob1
    20th February Developer 2 Permalink
    New snapshot 161:
    Keyboard shortcuts are now based on en-US layout, no matter what layout you actually use
    This fixes things like 'y' and 'z' being reversed on QWERTZ keyboard layouts, now, 'y' will continue to be zoom

    @furlong_p (View Post)
    I fixed most of the issues. For some reason, = still doesn't work, but a bunch of other keys do work properly now, like 'y', 'z', [, ], and ;

    @DarkGlaze12 (View Post)
    I definitely can't reproduce that, and I can't imagine how that would happen either ...

    @Paulo_fofis (View Post)
    I did a few things for mobile users in this update, but not as much as I wanted. I do have a pretty big idea for how to improve the mobile interface, will try to do it eventually but not sure when I actually will.
  • furlong_p
    20th February Member 0 Permalink

    The German layout has a further annoyance, called "dead keys". Both the console hotkey ^ and the key the "Reset Pressure" hotkey is on ´ are dead keys. A dead key does not immediately result in an input, but it waits for a further key to be pressed. For example, pressing ^ and then a results in â, pressing ´and then e results in é. Dead key issues affect the console (after opened, the next key press will result in a ^ character being inserted, not the actual key pressed). And, the dead key issue might be the reason the "Reset Pressure" doesn't work, yet. For a few non-keyboard related issues, I'll better open a separate topic, I guess.

     

    Edit: @jacob1 (View Post)

     Just checked out Snapshot 161 and the Reset Pressure does work normally (using the key left of Backspace). Reset sparks does, too.

     

    Edited once by furlong_p. Last: 20th February
  • Anthonyg5005
    20th February Member 0 Permalink

    @jacob1 (View Post)

     When you press change resolution your mouse cursor dissapears and this wawsn't a problom before the update and I can't play without fullscreen and change resolution

  • jacob1
    21st February Developer 0 Permalink
    @furlong_p (View Post)
    Oh thanks. I'm guessing it's a difference in how Linux vs. Windows handles it. I'm on Linux, I added qwertz as a keyboard layout. Whenever I press = or ` (american locations), I TPT doesn't receive any kind of keyboard event. It's waiting for me to press another key. Perhaps on Windows the key event comes in anyway, with an additional event sent once a letter is typed.

    You also helped me somewhat test the unicode input. Version 94.0 added unicode support. When I have Lua listen in on the "textinput" event, I can see that pressing '=' then 'a' will print a unicode character (same with any other letter that's a valid input). We don't actually have these characters in our font yet ... but it's awesome that unicode input will work once we enable it.

    Also, I've fixed the console bug now. When entering the console, TPT should now reset the text input state. So if it thought you were inserting a special character, it will now forget about that.

    I'm about to release snapshot 162 with this fix and another minor fullscreen fix.

    @Anthonyg5005 (View Post)
    The cursor shows up just fine for me. Not sure what to do about that ... I will add another fullscreen option in the next version, maybe it will work for you (the "new" option is just that I made normal fullscreen without "change resolution" actually usable)
    Edited once by jacob1. Last: 21st February
  • drray
    21st February Member 0 Permalink

    Umm jacob1 

    I can't open powdertoy.exe file after 94.1 update.

    It says I don't have authority to open file.

    94.0 worked perfectly but 94.1 doesn't work.

    Can you give me some help please?