Subframe Chipmaker Mod

  • mark2222
    19th Nov 2016 Member 0 Permalink

    @gunpowderTR (View Post)


    In my case, it's not my mod. Vanilla TPT uses about 500M as well.

    1. How are you measuring memory usage? I'm checking "VIRT" in top.
    2. Does memory usage continue increasing with continued use?
    3. Are you able to reproduce it? If so, could you provide specific steps? Something like "open my mod, leave it for 5 minutes, check top" or "open my mod, open all the fp saves, check top" would be good.
    4. How much memory does vanilla TPT use, if you did the same thing?

    Sorry for the trouble. I'd really like to fix any memory leaks, but I can't do so if I can't reproduce it. I'm on Ubuntu too, and the closest I could get to 1G memory usage was vanilla TPT using 700M.

  • whenpeopledying
    1st Dec 2016 Banned 0 Permalink
    This post is hidden because the user is banned
    Edited once by jacob1. Last: 6th Mar 2017
  • mark2222
    6th Mar 2017 Member 0 Permalink

    Version 1.1 released!


    Merge changes in snapshot.
    Add stack tool.
    Add stack mode.
    Give drawn CRAY a ctype of SPRK.

  • motaywo
    28th Mar 2017 Member 0 Permalink

    I saw your mod, and instantly knew that it seemed to be the perfect thing, but after I downloaded the mod and tried to open it, it crashes instantly. I've tried redownloading (no change), so I just wanted to let you know in case others are having this problem.


    I'm using OS X 10.11.6, and my computer can run both the official release or Jacob1's Mod without difficulty.


    Since my knowledge of programming/coding is roughly on par with my knowledge of how to play golf (aka, none), at this point I'm essentially helpless. ¯\_(?)_/¯

  • jacob1
    28th Mar 2017 Developer 0 Permalink
    @motaywo (View Post)
    Well that is interesting because this mod is compiled in the same way, at the same place as my mod and official TPT. If you can't launch this, it might signify a problem in the code that was introduced recently. Are you able to run the snapshots?

    OS X doesn't get tested very well because I don't have a mac.
  • mark2222
    29th Mar 2017 Member 0 Permalink

    @motaywo (View Post)


    Thanks for reporting! Sorry for the crash. As jacob1 said, we don't have macs so OS X builds will always be less stable.


    Anyway, I borrowed a mac and confirmed that my mod does indeed crash on OS X due to a linking error (something about libsdl1.2). It doesn't crash when I cross-compiled it from Linux myself, so it should be a problem with the build server's new build script. It is strange that the snapshot didn't crash when I tested it.


    For now, here's the working build (temporary link):

  • motaywo
    29th Mar 2017 Member 0 Permalink

    @mark2222 (View Post)

    @jacob1 (View Post)


    Hi! Thanks for the fast feedback! I've just tried, and both the new build (for Mark's mod) and the snapshot runs fine. I think it was an isolated problem in the code, and whatever the two of you did, it seems to be completely fixed now.


    If you want, I can try to stay on top of the new updates/snapshots (on OS X) and give you a holler if there are any problems. Thanks again!

    Edited once by motaywo. Last: 29th Mar 2017
  • jacob1
    9th Apr 2017 Developer 0 Permalink
    @motaywo (View Post)
    Can you run the mac version again? I released a new build that should fix it.

    The problem was that the build server had the old cross compiler still installed and it was using the SDL I compiled for that.
    Edited once by jacob1. Last: 9th Apr 2017
  • jacob1
    25th Jul 2017 Developer 1 Permalink
    @mark2222 , your mod is updated to 92.0 now

    Anyone that has the current version 2 can start it and will get an update prompt in game
  • danieldan0
    1st Sep 2017 Member 0 Permalink

    I have found a bug. When you try to paste something, and part of it goes out of the TPT window, TPT throws a read/write error.