Official Game Feedback

  • jacob1
    19th Jun 2013 Developer 4 Permalink
    List of bugs

    I just put together a list of bugs I know about, by looking at all the recent threads and comments, and also my bug posting save. It has really short descriptions for myself, I understand what they all mean but other people might not.

    These are listed in no particular order of importance, mostly just date reported. Some Most barely count as bugs.

    The old list is here and is no longer updated, but a list of previous fixed bugs is there.

    2) thumbnails still get mixed up - maybe fixed?
    3) fullscreen on mac - updating SDL should fix it
    4) mass deleting saves only will actually remove the first from showing - server side bug
    5) can't delete your own saves from fav. section
    6) local browsers don't cache thumbnails
    7) limit to 61 fps always in interfaces?, glitches on high fps cap
    8) can't see full save name in browser if too long, need to click it first
    9) element search doesn't include 'related' section that searches descriptions
    10) plasma arc lag, EMP lag -> fix?
    11) fix LIGH branching when going up, fix nearest_part
    12) SING (and DEST?) can't eat PBCN/BCLN - really just personal preference ...
    16) -> PSTN bug
    19) set type all x100 doesn't error
    20) elementCount is inaccurate on ctrl+z, when replacing particles in saves, maybe some other things
    21) (weird background color on load)
    22) Wall drawing doesn't allow even sized brushes, also the arguments to the simulation api wall drawing functions don't make any sense
    24) Element descriptions should be drawn with drawtext_outline

    debug lines in persistent mode:
    ambient heat not loaded / saved in saves
    1140272: you can draw stickmen (and SPWN's) on top of other elements
    elements created be drawn on walls they don't belong
    picking a color changes the default colors, no way to deselect them
    right click deco presets - all selected
    deco buttons don't have color
    huge upload icon is missing (the one with the cloud)
    no replace mode
    no CAPS LOCK (specific delete)
    when clicking "login to post comment", it doesn't update the sign in button on the main page (still says "[Sign in]")
    !bubble 100, 100 crashes (space in between)
    "C" not displayed next to temperature in HUD
    tpt.get_numOfParts() is wrong
    right ctrl/shift/alt doesn't work. Maybe re-enable it for now until a replacement is added?
    for i = 1,200 do tpt.el[string.lower(tpt.element(i))].menusection = elem.SC_SOLIDS end -> -> FRME and past aren't visible.
    Bottom row of saves in the local save browser isn't shown.
    sim.decoBox uses rx and ry parameters yet rx and ry are never used inside it
    save browser uses 100% cpu
    alt-snap: when the angled ones go off-screen at the top or left, the line breaks and isn't straight
    photon colors in HUD don't fade out when over quickoptions
    more than one sign appears in one place sometimes
    setting color to 0xDEADBEEF makes pink button and blue element
    erasing grav wall doesn't reset zones: 1223463
    17) bmap_blockairh -> insulators don't block ambient heat
    15) stkm can die from HSWC even when turned off
    13) should allow longer than 4 chars
    1) can't move signs into zoom window
    14) tpt.el.asdf.color = fdsa doesn't change the color of the button
    18) d:1382380 -> NEUT can move particles backwards through energy wall
    23) Crashes when pasting in linux when there's nothing to paste (window that copied text is gone)

    My own personal todo list, some of which I might not even want to do anymore but did at one point. Ignore this.

    todo: {t:15100|Official Game Feedback} {u:38642|jacob1}? {s:bombs|search for bombs} maybe others?
    todo: tooltips on deco buttons, add black preset
    todo: missing key combos: c, t, r, b, n, m; add back?
    todo: disable recording except by lua
    todo: custom view modes
    todo: copy in deco menu only copies deco
    todo: rename element files like dcel.cpp, rename PT_ things to match more
    todo: improve flood fill with walls / edges
    todo: maybe if's for console? ex. !set type all none if life > 10
    todo: BVBR gets heavier as it absorbs more?
    todo: combine rand()'s in fusion, others; like PIPE does
    todo: fix ETRD (and maybe EMP) lag
    todo: hold 'f' for slow motion
    todo: - python 3 generator
    todo: new options menu. possible new options: turn off sparks, turn off network usage, GSPEED
    todo: reorganize source a little
    todo: lua functions to change mouse coords with zoom, do the rest of the quickoptions, debug mode, edge mode, air/grav modes, get save id, default ambient heat air temp, set selected element / brush size (not with functions?), reset temps/pressure, do sign, prop, and wind stuff, control stickmen, get sim->elementCount. Check why tools draw too lightly in tptmp (missed steps?) - fixed
    todo: - PROP redo
    todo: option to have signs drawn under particles instead of on top
    todo: property display mode, can display life/tmp/tmp2 in red/green/blue/greyscale, customizable in new options menu
    todo: tool that deletes walls and particles
    todo: FAST / SLOW, velocity setting tools
    todo: replace mode doesn't work for floodfill
    todo: f5 refresh option, not everyone likes ctrl+r
    todo: lua function for can_move
    todo: in grid mode, grid drawn between each pixel in zoom?
    todo: pressing tab moves to next deco editor box
    Edited 49 times by jacob1. Last: 21st May 2014
  • cyberdragon
    20th Jun 2013 Member 0 Permalink

    Jacob1...I'd smack you if I could. You have broken spark, it's render is screwed up just like I thought, like switch conducting to silicon some places but not others and spark jumping farther gaps than it should. Remove all insulation from this save and go to the top floor. Then click floor 3 and pause. Watch the far right circuits with F and you will notice something funny happens with the middle one. Now look where the elevator is. O_O Yes, I'd say something is broken.


    EDIT: Fixed it, and it only happens with gold, which clones spark with new data, so basically I think there is a variable malfunction in spark.

  • jacob1
    20th Jun 2013 Developer 0 Permalink
    @All4Staals (View Post)
    This is not the place for element suggestions, just read the things at the top of the first post

    @cyberdragon (View Post)
    GOLD conducts specially, and if anything Simon broke it since he made GOLD

    gold will conduct normally, a two pixel radius just like anything else. But it also will conduct on 4 edges that are 4 pixels away. It won't conduct 3 pixels away though.

    very bad diagram: G is the sparked GOLD, M is METL, S is SPRK after one frame

  • Sailnir
    20th Jun 2013 Member 0 Permalink

    I think a good way to fix lag is to have water that acts as a solid beneath the first layer or maybe 20 layers to account for pressure but if the movement of every particle did not have to be determined it could function better.

  • Dingolo
    20th Jun 2013 Member 0 Permalink
  • Plutonium84
    20th Jun 2013 Member 0 Permalink

    Yeah , it is cool

  • sandstorm
    20th Jun 2013 Member 0 Permalink

    what of something like reactors that rely on pipes to move water from large resiviors?

    i have a feeling that that could be a MAJOR issue, with water equalization and all.

  • jacob1
    21st Jun 2013 Developer 0 Permalink
    yes, it totally would not work with water equalization and a bunch of other cases. Although water could probably be rewritten somehow to be less laggy, the liquid movement code is extremely overcomplicated. But changing liquids to solids ... is just a bad idea.
  • Kikinicij
    21st Jun 2013 Member 0 Permalink

    Water acts like a powder when falling but when air is added under it, it becomes faster at movement falling when the air is comming up and it spreads out the air inside it unlike a powder.

  • wolfy1339
    21st Jun 2013 Member 0 Permalink

    add an option to increase screen resolution of game even in fullscreen mode in the new options menu planned.

Locked by jacob1: Old / not enough space in first post