Official Game Feedback

  • LBPHacker
    9th February Developer 0 Permalink

    Can confirm, here it is. Been there for a long time. We don't touch it because it doesn't seem like it poses much of a problem.

  • tt_thoma
    17th February Member 0 Permalink

    @jacob1 (View Post)

     That normal the BUBW (carbonated water) EXPLODES when it releases CO2?

    Can you disable the break effect under pressure and make it just activate it with the Newtonian gravity because I would like to combine the pressure resistance and the high melting point (with TUNG)?

  • dhdoctor
    21st February Member 0 Permalink

    Sorry if it has already been reported but when using the replace tool with plsm it just deletes what you are replacing.

  • jacob1
    21st February Developer 0 Permalink
    @dhdoctor (View Post)
    Replace tool is broken in general in the snapshot, there's other bugs too. It has already been fixed for the next version :)

    And the next version will come this weekend if all goes well. I've been struggling with the Android port for the last two weeks.
  • rafaelucian22
    26th February Member 0 Permalink

    There is a bug with replace spark it forms metal. I'm not sure if thats intentional but yeah.

  • jacob1
    27th February Developer 0 Permalink
    Version 95.0 has now been officially released! (Note - Android update still pending with Google.) Thanks to all the beta testers that found and reported bugs, everything mentioned in this thread should be fixed. As usual, if there are any more bugs, report them here.

    Changes since the 95.0 beta:
    - Fix https requests on MacOS
    - Add "Perfect Circle Brush" option (on by default) to allow using the old circle brush
    - Fix replace mode simply changing type, instead of resetting properties back to default as intended
    - Fix crash when failing to remove tag
    - Fix crash when overwriting existing local saves
    - Fix fighters sometimes loading from saves with no element
    - Fix bug where deco renders on EMBR in save thumbnails
    - Fix text prompt interface (rarely used, only for some Lua scripts)
    - Restrict saved version to 95.0 if 95.0 features are present - signs with macros, LSNS .with .tmp
    - Update Windows version to SDL 2.0.10

    Sorry for the huge delay between the beta and the final release. Everything was mostly ready, but turns out the Mac version was broken and couldn't make https requests. Wouldn't make sense to release a version with no online functionality ... It took a while to figure out which version of the mac SDK to use. TPT now requires 10.9 on mac.
    After that, I went to compile the Android port, and found out it also was unable to validate https requests. This was even more complicated to fix than the mac version. In the end I upgraded the sdl port I'm using, compiled curl and openssl myself, realized openssl wouldn't work and compiled boringssl instead, THEN it finally worked. Took about 2 weeks before everything was working.

    This update has no new elements so might appear light on features, but is actually huge from a code refactoring perspective. The game now uses https, it's unacceptable to still be using plain http in 2020. Other major improvements were made, such as to the loading speed of thumbnails in the browser, stretchiness / rendering of stamps in the stamp browser, and element creation hooks (which will greatly benefit Lua scripts).

    In the future for 96.0, there's a few things I want to do. I do want to add more elements in 96.0. LITH and VSNS have already been pull requested, but I might look into adding more non-electronic elements. Another large pull request adds key remapping support. I'd also like to add support for the latin-1 and Cyrillic character sets (this will require a website change too), work was done with this in 94.0, but we haven't done much with it since.
    Edited once by jacob1. Last: 27th February
  • Planet
    28th February Member 0 Permalink

    i experienced a bug where the brush doesn't follow the cursor when i'm using a drawing pad or drawing tablet. but when i use my mouse the brush follows the cursor just fine. 

  • MP3450
    29th February Member 0 Permalink

    Having just switched over from 94.0 to 95.0 I've notice that the new update is increadably blurry. I'm not enteirly sure why this is?

    I've tried messing around with all the setting, The change resolution button, Forced integer scaling, fullscreen, different window scaling and turning on and off resizable. 

     

    Im on a mac and my normal screen resolution is 5120x2880, is that two high for the game or something?

     

    Plz help, it is pretty much unplayably blurry

  • jacob1
    29th February Developer 0 Permalink
    @Planet (View Post)
    Hmm, will have to see if anyone with a drawing tablet can reproduce. I have a touchscreen on my laptop, but that isn't the same thing.

    @MP3450 (View Post)
    Sounds like you played with all the options I would have recommended. "Forced Integer Scaling" helps a lot in fullscreen for most users.
    Maybe play around with mac options? See if MacOS itself gives you options to disable things like dpi scaling if you right click the app. I've heard of someone doing this a long time ago, but I don't know the details.
    If that doesn't work, try some alternate versions of TPT like the snapshots or my mod, both of which were built differently.

    I did upgrade to the latest version of SDL2 (2.0.10), which is the thing we use to render to the screen and handle input (mouse / keyboard). It could be a bug with this update.
  • GRIEFERSX101
    1st March Member 0 Permalink

    I cant post topics