Subframe Chipmaker Mod

  • mark2222
    24th Jun 2020 Member 0 Permalink

    @INFINITY-BOI (View Post)

    So, to be clear, you have a PSCN at (x, y) and a CONV at (x, y+1), and when you stack them, the CONV comes out on top?


    If so, that's intended behavior. The stack order should be the original subframe order of the particles before stacking. If you want the CONV to come out at the bottom, you should put the CONV above the PSCN.

    25th Jun 2020 Banned 0 Permalink
    This post is hidden because the user is banned
  • thepowderkeg
    9th June Member 0 Permalink

    why is scale 2 = scale 3?

    edit: also scale 3 is scale 4 wich i dont tink even is a scale also more specifically i manually set the scale with notepad and im mean 2 = 3 = 4 as in the windo size is that big

    Edited once by thepowderkeg. Last: 9th June
  • mark2222
    20th July Member 0 Permalink

    A small update for 96.0 96.1 has been released. This is an ALPHA release, not everything has been tested yet. Expect a cleaner release soon.



    • Merge changes in 96.0.
    • Fix config tool large stack crash bug.
    • Fix local load unsaved changes bug.
    • Change "c" prop tool shortcut to "c:".


    @thepowderkeg There was no changes made to the scaling code. Do you see it perform differently from the unmodded version?

  • mark2222
    26th July Member 1 Permalink

    The full release is out, with a handful of bugfixes and features! You're probably most interested in the stack edit feature, which allows you to edit particles in the middle of stacks without unstacking and restacking them.


    v1.10a → v1.10:

    • Move DRAY/DTEC coloring into Lua.
    • Prevent Tab from changing the brush.
    • Fix non-brush-created CRAY having ctype SPRK.
    • Make subframe recording only accessible from Lua.
    • Make particle order reloading faster.
    • Make debug HUD more compact.
    • Confirm when saving unclean state instead of reloading particle order.
    • Only show stack tool warning once when holding down on stack.
    • Add stack edit feature.
  • mark2222
    31st July Member 1 Permalink

    Just a bunch of minor tweaks and bugfixes.



    • Change stack mode shortcut to Shift-D.
    • C no longer switches out of config tool.
    • Rearrange properties in property tool.
    • Show subframe debugging position in the HUD.
    • Show CRAY FILT mode in the debug HUD.
    • Autoreload (if enabled) when attempting to save with particles out of order.
    • If disabled, prevent autoreload when subframe debugging.
    • Fix stack edit ctype display bug.
    • Fix save location on command line open.
    • Fix property tool rect/line bug.
    • Fix interesting change detection not detecting killed particles.
  • David-P
    3rd August Member 0 Permalink

    I have these problems with the new actualization v1.11 (2/8/2021),

    • if you edit stacked particles or empty space (with stackE shortcut) the mod messes up the rest of the particle orders and destroy anything. Solved, write on commands: tpt.autoreload_enable(1)
    • Value of stackE cannot reset easy, example: if you select particle 20, you cannot return fast, you will need to use the shift + E shortcut 21 times.
    • The program give me an unrecoverable fault : bad allocation.
    • Curious data: if you press shift + D + F will be actualized particle order to the mouse pointer and the end of the simulation in the same time.

    I love how the debug bar displays the current particle in ejecution in shift + space.


    Thanks, good work!!

    Edited 14 times by David-P. Last: 3rd August
  • mark2222
    3rd August Member 0 Permalink

    @David-P (View Post)


    Thanks for the feedback! I'll look into providing a shortcut to escape out of stack mode, probably Shift-T. As noted in the README, creating particles in stack edit mode necessarily reloads particle order; I might shift things around so that particle creation is disabled when autoreload is not enabled. Shift + D toggle stack mode, which reloads particle order for similar reasons; that includes completing particle updates to the end of frame, so that observation isn't surprising.


    "unrecoverable fault : bad allocation" is definitely a bad bug, though. Do you remember anything about what you were doing or trying to do when it happened?

  • David-P
    9th August Member 0 Permalink

    @mark2222 (View Post)

     I was copying and pasting a DRAY element that contained a 3-layer stack into the simulation map tpt.autoreload_enable(1). That was enough at that time for it to fail in this way, when I tried again and the program works correctly.


    Edited 2 times by David-P. Last: 9th August
  • LBPHacker
    9th August Developer 0 Permalink
    Have you manually cranked up your undo history limit?