Modding TPT

  • xetalim
    16th Jun 2013 Member 0 Permalink

    @greymatter (View Post)

     hum, you compiled?

  • firefreak11
    16th Jun 2013 Member 0 Permalink

    Whatever you do, do NOT randomly run the python file. This completely destroyed my project for days, and it is a terrible thing to have happen.

  • jacob2
    16th Jun 2013 Member 0 Permalink
    Either use the generator, or don't. Preferably use it. Change all the directive comments to say DERP and not BGLA, but probably you didn't change the I'd from 46. I think the last element added was 172, so you should use 173, but I can't remember. Open up elementclasses.h if you want to check, also make sure its in at the end of elementclasses.cpp.
  • greymatter
    16th Jun 2013 Member 0 Permalink
    @jacob2 (View Post)
    I did them all correct.
    @firefreak11 (View Post)
    0_0 are you serious? because i did run it 3-4 times afer installing python for no reason...
  • wolfy1339
    16th Jun 2013 Member 0 Permalink

    Did you compile it after you added the element?

  • firefreak11
    17th Jun 2013 Member 0 Permalink

    @greymatter (View Post)

     yes, it completely ruined mine and i had to delete all my source and download it again from my thread and re-code all my new stuff for the next version that i had been working on.

  • boxmein
    17th Jun 2013 Moderator 0 Permalink
    And if ALL else fails, there's the same thing generator.py generates at the end of http://boxmein.x10.mx/tptelements/
  • Plutonium84
    17th Jun 2013 Member 0 Permalink

    Boxmein's solution is a total success.

    jacob 2:

    Either use the generator,  or don't. Preferably use it. Change all the directive comments to say DERP and not BGLA,  but probably you didn't change the I'd from 46. I think the last element added was 172, so you should use 173, but I can't remember. Open up elementclasses.h if you want to check,  also make sure its in at the end of elementclasses.cpp.

    Better safe than sorry. True that.

  • mniip
    17th Jun 2013 Developer 0 Permalink
    @firefreak11 (View Post)
    what exactly got "ruined"
  • greymatter
    17th Jun 2013 Member 0 Permalink
    @firefreak11 (View Post)
    OKAY
    I made a new folder, re extracted the TPT source, required libraries and made a new VC++ project. Now no more generator.py messups. But i did what i did before, coding element DERP, and it did not appear in the mod.
    @boxmein (View Post)
    I did that, but nothing happened.

    How does the .exe in builds folder work? Does it read src\simulation\elements everytime to include new elements? I don't think so. That's why i said i still must be missing something. HELP PLEASE....