Jacob1's Mod

  • jacob1
    17th August Developer 0 Permalink
    Version 43.4 Released!

    Version 43.4 2019-08-17
    Redo prop tool ui. Refactor some code relating to prop tool and prop setting Lua functions. Refactor gravity.cpp. Fix crash when save info couldn't be downloaded. Redo colors in "new" interface slightly, the new interface is no longer pure white, instead it is slightly gray like the official version. Move the black bar that appears in the element search ui. Numerous updates from the upcoming official 95.0 release (still more to copy over): thread / search signs are now red and purple, respectively. Add new sign types, {type}, {ctype}, {life}, {tmp}, {tmp2}. Other text can now be put alongside these custom sign types. Add .life serialization support to LSNS. Other tpt++ updates that aren't as noticeable.

    This release fixes a crash someone reported yesterday. It also has all the changes I've been copying from the upcoming 95.0 release. Lots of code refactors too, because I've been in a refactoring mood recently.

    Download Version 43.4 for Windows
    Download Version 43.4 for macOS
    Download Version 43.4 for 64 bit linux.
    Download Version 43.4 for 32 bit linux.
  • Bortan
    25th August Member 0 Permalink

    @jacob1 (View Post)

     Hey! I noticed today while trying to send in a bug report that there seems to be some sort of problem with the bug report thingy. The first one I attempted to send crashed my client, and the two I tried after gave a http 605 error.

     

    Additionally, and what I was originally trying to send in, for some reason newtonian gravity being on will sometimes cause water and other particles to act as though there is a source of gravity present, even though there isn't.

     

    One more thing, the latest update seems to have broken one of the scripts I use, reporting that 0 is not a particle number.

     

    The specific line it had a problem with was

    tpt.set_property('type', 0, x, y)

     

    When using the Prop menu, despite it being still being set to tmp from the last time I used it it tells me "Invalid element name"

     

    Another one, an element I had labeled pwht, Powered Heater, seems to have disappeared. It has been replaced in saves where I used it with an element called EXPL, which appears to be a more explody bomb with some interesting properties, one of which is how difficult it is to acquire. It does not persist between tabs when I middle click it, being replaced with the other element I have which was already labeled EXPL, and will disappear when I reload a save where I saved it, other than the ones where I had pwht.

     

    Was pwht one of yours? I can't seem to find it in my scripts. Perhaps I'm misremembering the name because I can't locate it anywhere.

     

    I have forgotten how to access the search menu, how is it done again?

     

    Console is also fucky, can't set things to none.

    Edited 7 times by Bortan. Last: 25th August
  • jacob1
    25th August Developer 0 Permalink
    @Bortan (View Post)
    The tpt.set_property thing looks like a bug, I will fix it. Not sure why the bug reporter in my mod is broken either ... will also have to fix that.

    I made some changes to newtonian gravity handling in the most recent update, there must be an issue clearing gravity, causing it to not actually be cleared when turning it off sometimes. I can't reproduce it at the moment though.

    I see the PROP bug. It's setting the dropdown to the previous property (.tmp), but it's actually .type when you hit enter.

    PWHT was an element from my mod that I removed because I didn't like it. When doing the PROP tool refactors, I didn't feel like updating it. The whole element is based on setting properties, so it would have needed some changes. Instead of doing the changes, I removed the element entirely.

    Search menu is accessed with 'e'.


    Thanks for reporting all these bugs! I will try to get an update out this week. I just got back from vacation so may not work on it tonight.
  • Bortan
    25th August Member 0 Permalink

    @jacob1 (View Post)

     Alright man! Thanks for the response, go ahead and take your time! Shame about pwht, but I'll find another way to cool things. Is the code for PWHT somewhere I can get at it? I'd like to try to use it anyway.

  • jacob1
    25th August Developer 0 Permalink
    @Bortan (View Post)
    Here is the code from before it was deleted: https://github.com/jacob1/The-Powder-Toy/blob/f77713964c879cef24a70b939b0da0320fe56d6c/src/simulation/elements/PWHT.cpp

    I'll look into adding the element back. It isn't too hard to implement. I just didn't really like how it was done. It's *much* more than a powered heater. That name is misleading about how powerful it really is. It can actually set all properties, not just .temp. But it only works via flood fill, and I never liked that.

    Maybe I can add more features (such as setting properties in a certain range, a property ray, and / or limiting it to specific .types). Or I could just leave the secret property setting features the same. Not sure how many extra properties I have to work with, I see .tmp and .tmp2 are already used for something.
    Edited once by jacob1. Last: 25th August
  • Bortan
    26th August Member 0 Permalink

    @jacob1 (View Post)

     Thanks man! I can't believe I never knew it could do those other things, I'm really beating myself about my head right now! I'll be happy to use whatever you end up adding!

  • jacob1
    28th August Developer 0 Permalink
    Version 43.5 Released!

    Version 43.5 2019-08-27
    Fix rare issue that prevents loading certain saves with Lua elements. Fix setting type to none in !set and tpt.set_property. Fix prop window always resetting to .type, without indicating it was doing so. Add back PWHT because some people still use it. The feature where it can set any property (not just .temp) was adjusted slightly. .tmp2 no longer needs to be set, it can now set pavg0 and pavg1, and setting .type is now ctype 3 instead of 0.

    Download Version 43.5 for Windows
    Download Version 43.5 for macOS
    Download Version 43.5 for 64 bit linux.
    Download Version 43.5 for 32 bit linux.

    @Bortan (View Post)
    All of the issues you mentioned are fixed now, except for the Newtonian Gravity one (couldn't reproduce). I also fixed the bug reporter (was able to fix it with a server-side change, but I think it might be a libcurl bug, or maybe my server is just being stupid). PWHT is also added back, and works mostly the same as before.
  • Bortan
    31st August Member 0 Permalink

    @jacob1 (View Post)

     Hello again!

    A bit more on that newtonian gravity one, it looks like particles go towards each other and thats what I've been seeing. For example, if I put two masses of water down with newtonian gravity on, they move towards each other.

     

    This is true for both powders and liquids, and for both modded and unmodded elements.

     

    Although now that I think about it, this is alot more gravityish than the old way, so this might be working as intended?

     

    Video showing it:

    https://www.youtube.com/watch?v=JUDKNUnLHDc&feature=youtu.be

     

    This does happen in all the gravity modes, it's just easiest to see with it off.

    Edited 2 times by Bortan. Last: 31st August
  • jacob1
    31st August Developer 0 Permalink
    @Bortan (View Post)
    It's probably a Lua script that does that, because the mod by itself definitely doesn't do that.

    Might also explain why your game is so laggy.
  • temporaryaccount
    1st September Member 0 Permalink

    I don't know if this is just my problem, but the MacOS app doesn't work when double clicked. After the disk image mounts, you're supposed to be able to just drag the app bundle into the applications folder and open it. However, this time the app icon has a white circle with a line through it on it and gives this message when double clicked:

    You can’t open the application “Jacob1's Mod” because it may be damaged or incomplete.

     

    I opened the package contents and ran the executable file in terminal, which worked fine (including loading my pref file). I am running MacOS 10.14.6 and just downloaded the latest version of your mod.

     

    I couldn't find the program in my applications folder since I migrated from my old macbook so I decided to redownload it but this happened.

    Edited once by temporaryaccount. Last: 1st September