Jacob1's Mod

  • stargate38
    2nd January Member 0 Permalink

    I can't open the following save with it:

     

     

    It gives me "An error occurred when parsing the save: Unable to decompress (ret 0)". What's wrong with it?

  • jacob1
    3rd January Developer 0 Permalink
    Version 38.2 Released!

    Version 38.2 2018-01-02
    Fix ren.colorMode() crash. Fix crash when opening saves from the command line. Improve bson error handling. Fix "Unable to decompress (ret 0)" error when attempting to load certain saves.

    Fixed two obscure bugs with the save rewrite. Also one bug breaking tptmp, but from what I could tell nobody except me was actually affected for some reason.

    Download Version 38.2 for Mac OS X 10.6+
    Download Version 38.2 for 64 bit linux.
    Download Version 38.2 for 32 bit linux.

    @stargate38 (View Post)
    Thanks, I fixed it. Apparently the author deleted the save like 15 minutes after I made a fix. Good that I was able to view it in time ...
  • TITANICiceberg50
    11th January Member 0 Permalink

    @BloodLust (View Post)

     

    jacob1:

    Jacob1's Mod, tpt's longest lasting and most popular mod. My overall goal isn't to add a bunch of elements you can forget about, it's to create a more stable tpt version with lots of new features and other things not fit for the official version, things like moving solids, multiple tabs, TPT multiplayer, and others.

    Its not going to get in that NEVER
    Edited once by TITANICiceberg50. Last: 11th January
  • jacob1
    5th March Developer 0 Permalink
    Version 39.0 Released!

    Version 39.0 2018-03-04
    Fix "dns mismatch" error when starting game without internet. Sort local saves alphabetically. ctrl+shift+p shortcut for putting PROP on right click. Add cyclone tool from version 93.0. Large rewrite of some simulation code to support doubling the element limit. Disabled until 93.0 comes out due to incompatible save format changes. Add a warning message when stealing saves. When finding particles, show how many were found in HUD. Ignore 503 errors from update server. Redo ANIM somewhat and fix crash when ctrl+z-ing ANIM.

    This update is to prepare for 93.0, so that once 93.0 is out I can just do a few quick changes. Report any bugs or broken elements you see. I changed pretty much every single element that has an update function and all the core simulation code. Most of it was through find+replace ... but there were still a few bugs found when I did it in the snapshots.

    Download Version 39.0 for Mac OS X 10.6+
    Download Version 39.0 for 64 bit linux.
    Download Version 39.0 for 32 bit linux.
  • Killedbydeth2
    5th March Member 0 Permalink

    Whenever I try to place life, it's always GOL- this happens with every life type, and it's not a mod I've downloaded as it happens on a non-modded version too.

    EDIT- It works on ver. 38.2, so it's happening in the new version

    Edited once by Killedbydeth2. Last: 5th March
  • jacob1
    5th March Developer 0 Permalink
    Version 39.1 Released!

    Version 39.1 2018-03-04
    Fix GoL brushes

    Download Version 39.1 for Mac OS X 10.6+
    Download Version 39.1 for 64 bit linux.
    Download Version 39.1 for 32 bit linux.

    @Killedbydeth2 (View Post)
    Fixed, thanks
  • Killedbydeth2
    5th March Member 0 Permalink

    Yep, it works, thanks!

  • itanimulliking
    5th March Banned 0 Permalink
    This post is hidden because the user is banned
  • phox
    5th March Member 1 Permalink

    There's an element called ball in this mod that works sort of like a moving solid, it's very bouncy though

  • NUCLEAR_FOX
    5th March Member 0 Permalink

    @phox (View Post)

     Which also lags sometimes and doesn't work half the time. That was my experience, unless he's fixed it.