TPT Snapshots / Betas

  • jacob1
    20th August Developer 0 Permalink
    @NoVIcE (View Post)
    Can you give me a link to the save?

    You're probably behind a caching proxy. Some ISPs do this, they cache stuff like save data, and send you back the old one even though a newer version of the save it available. It's an awful way for them to save money.
  • NoVIcE
    20th August Member 0 Permalink

    @jacob1

     

    All of my saves do that. But heres one. Thanks for the time spent caring about the people

     

    id:2176769

  • jacob1
    20th August Developer 0 Permalink
    That save was last updated 12 minutes ago. If you don't see the update, then it is the issue I described. I don't think there is any way to fix it. It's your ISP's fault.
  • NoVIcE
    20th August Member 0 Permalink

    @jacob1 but its happening since after the 92.1 update. Did you change anything?

  • jacob1
    20th August Developer 0 Permalink
    No, nothing was changed

    The only thing I will mention is that, there could probably be a server side fix for it (telling caching proxies to never cache saves), but I don't have the ability to do that.
  • cracker1000
    30th August Member 0 Permalink
    @jacob1 (View Post)
    Hey the deco icon bug is still present in snapshot 97.Its really weird i can't even use deco button once it happens have a look.
    http://imgur.com/a/UMdQ9 (in snapshot 97)
    https://imgur.com/a/r0xov (in snapshot 94 to 96)
    I hope it helps,
    Edited once by cracker1000. Last: 30th August
  • jacob1
    30th August Developer 0 Permalink
    @cracker1000 (View Post)
    what happens if you press 'b'?

    I'll have to keep trying some more I guess ... I was hoping it was a bug in the official version only and not the snapshots. I couldn't see anything obvious in the code that would lead to a situation where the button looks like that. And I wasn't able to reproduce it.
  • cracker1000
    30th August Member 0 Permalink
    @jacob1 (View Post)
    It happens randomly and right now i dont know any specific way to reproduce it.I rarely use official releases since snapshots are more frequently updated so I don't know if its presentin official version too.
    Maybe i will try once more to find a way how to reproduce it.
  • cracker1000
    30th September Member 0 Permalink
    @jacob1 (View Post)
    It appers to happen when there is a kind of load on cpu while playing tpt like using sing bomb mafe of snow or pasting an large decoed save etc.
    And this happens almost every time i paste sing bombs and this makes deco icon useless as once the icon is gone i cant even click it.
    Way to reproduce it.
    Make ice set tmp 999 ctype sing paste it randomly and repeat iam sure it will work.
    I am not sure but i think the code you made for multiple undo it causing it but still not sure.
    Hope it helps
  • jacob1
    1st October Developer 0 Permalink
    From snapshot 99:
    Fix buffer overflow in luasocket library
    Fix illuminati symbols appearing when rescanning stamps
    Remove 'r' record shortcut
    Add tpt.record function
    Recordings now go into recordings//, where timestamp is the time the recording was started. is returned by the tpt.record function. Each new recording starts the filenames over at 0 again.
    Now uses luajit, which gives a 10-40% speed boost when running lua scripts.
    Fix issue with molten STKM that could break the simulation and cause crashes
    Change version number to 92.5

    sorry for the long snapshot delay, shouldn't happen again.