Jacob1's Mod

  • Videogamer555
    October 2011 Member 1 Permalink
    Jacob1, BUG REPORT for your mod. When I heat up a piece of metal (or other material) with the heat tool (or do anything that makes a change in temperature so that not all the pixels on the TPT screen are the same temperature), even if just a few 10ths of 1 degree, your heat display mode with autorange should automatically make the hotter part show as "hottest color" and the coolest pixels show as the "coldest color". But it DOESN'T respond to objects heated heat tool (or most other heating methods). It only works if I use something VERY HOT like Plasma. Please fix your autorange heat display feature.
  • Atrayin
    October 2011 Member 0 Permalink
    Can you add WAY more frames for your Animated LCRY or if you can Infinite?
  • jacob1
    October 2011 Developer 1 Permalink
    @Atrayin (View Post)
    There is a limit of 25 frames because it uses a ton of memory, and probably wouldn't be able to save online with that many. I could probably make a lua command or something that will change the maximum, but creating/deleting it already takes a long time. If you floodfill create then delete the whole screen, it will freeze for a long time while it's freeing the memory.

    Also, you can already change the speed, just change the temperature to change how long the time is between each frame. I was also thinking about making some kind of gui for ANIM, I just haven't yet. If you want to fast-forward it, set the tmp2 of the pscn or nscn that activates/deactivates the ANIM, and the ANIM will start/freeze on that frame. There is no way yet to change the speed it goes at except with HEAT/COOL.

    @Videogamer555 (View Post)
    I must have changed something at the last minute, and I guess it doesn't work anymore. I'll try and see what I did, and change it back. I also just realized it doesn't work when paused, but on destroyable city 5, which is what I tested it with, it still appears to work. I don't know why it's only working for that yet.
  • Atrayin
    October 2011 Member 0 Permalink
    @jacob1 (View Post)
    and while your online, have you added anything yet?
    and when will the next update be?
    (Sorry if i'm annoying you) 
  • jacob1
    October 2011 Developer 1 Permalink
    @Atrayin (View Post)
    To check if I added something, you can always go to github. When I add something new, it's usually on there for a while before I make a new version of my mod and post about it.

    I just fixed automatic heat mode and put it on github, so redownload it. The problem was that I didn't want to make an extra loop through all the particles in case it caused a liitle lag, so I put it in an existing loop, but the code wasn't always hit because I put in in the wrong place. I put it in its own loop, and now it always calculates the right highest and lowest temps.

    The next official update will probably be when I add a few more elements that people suggested, or whenever I feel like it. I sometimes update the .exe on github when I make a new commit, so you can always look there.
  • Atrayin
    October 2011 Member 0 Permalink
    @jacob1 (View Post)
    Github isnt working for me it says an error or something everytime i go there...
  • CrimsonCloud
    October 2011 Member 0 Permalink
    Truth be told I'm surprised simon or someone hasn't already used some of your elements and features anyway great job ;D
  • jacob1
    October 2011 Developer 1 Permalink
    @Atrayin (View Post)
    Did you go here? That link works for me.

    @CrimsonCloud (View Post)
    I probably just need to ask him to add this stuff in, and then i'm sure he'll say yes to some stuff.
  • Atrayin
    October 2011 Member 0 Permalink
    @jacob1 (View Post)
    Nope ill post a pic:
    image
  • jacob1
    October 2011 Developer 1 Permalink

    Atrayin:

    @jacob1 (View Post)
    Nope ill post a pic:


    That's strange. Can you even get to github.com? If you can, try searching for me and getting to my account that way.